Submitting a plugin


  • Admin

    Note: This category is only for released plugins. If you’re posting a WIP plugin, please do so in the WIP category.

    When posting your plugin, please be sure to include the following information:

    • The name of your plugin, preferably also in the title of your post
    • A description of what the plugin does and who it might be useful for
    • The minimum version of Glowstone that you support (Build numbers are fine)
    • The minimum version of Minecraft that you support
      • You can use a tag for this, eg 1.9.4 - Tags can be entered in the input below the post editor.
    • A list of any other plugins that yours depends on, as applicable
    • A list of any other plugins that complement yours, as applicable
    • Links to documentation, or in-topic explanations
    • Links to your downloads and source code, as applicable

    You could, for example, use a template like this. You don’t have to use this template; feel free to come up with your own post format as long as it includes all the relevant information.

    **Plugin Name**: *Short tagline*
    
    Plugin Name is useful for w x y z because a b c d. Because who doesn't like to xyz their abc, right?
    
    **Links**: [Github](#link_to_Github), [Download](#link_to_download), [Wiki](#link_to_wiki)
    
    This plugin requires Glowstone #xyz, and works with Minecraft x.y.z and above.
    
    ---
    
    This plugin requires [SomePlugin](#link_to_plugin), version `version` or later. It also works well with the following plugins:
    
    * [SomeOtherPlugin](#link_to_other_plugin): Because w x y z
    * [YetAnotherPlugin](#you_get_it_by_now): Because w x y z
    

    This would result in a post similar to this:

    SuperIronCommand: It’s time to party like it’s indev once again!

    SuperIronCommand is a simple plugin that allows your players to easily spawn extra iron ingots when they need them. It also allows you to configure a cooldown for the command - /iron - so that players don’t use it too often.

    Links: Github, Download, Wiki

    This plugin requires Glowstone #1337, and works with Minecraft 13.3.7 and above.


    This plugin requires SuperAwesomePluginLibrary, version 13.3.7 or later. It also works well with the following plugins:


Log in to reply
 

Looks like your connection to Glowstone was lost, please wait while we try to reconnect.